OpenTTD

Tasklist

FS#3205 - [OSX] Using OpenSFX sound set produces static

Attached to Project: OpenTTD
Opened by swp (swp) - Wednesday, 16 September 2009, 14:56 GMT
Last edited by frosch (frosch) - Sunday, 04 October 2009, 18:53 GMT
Type Bug
Category Core
Status Closed
Assigned To No-one
Operating System Mac OS X
Severity High
Priority Normal
Reported Version trunk
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

When trying to use the OpenSFX sound set, only static is output. However, the original sound set works fine.

I encountered this problem on PPC G5 Mac.
This task depends upon

This task blocks these from closing
 FS#2782 - [OSX] Port hopelessly outdated 
Closed by  frosch (frosch)
Sunday, 04 October 2009, 18:53 GMT
Reason for closing:  Fixed
Additional comments about closing:  in r17698
Comment by Ingo von Borstel (planetmaker) - Wednesday, 16 September 2009, 15:13 GMT
I cannot reproduce this. r17548 works fine for me with sounds and OpenGFX (Intel, MacOS 10.6 and 10.4) nor did I notice sound deficiencies before (but mostly I have it switched off...). What's your OS version and the OpenTTD version you tested it with?
Comment by swp (swp) - Wednesday, 16 September 2009, 15:42 GMT
I use OSX 10.4.11 on a G5 PPC Mac. I used r17536 and the latest nightly of OpenSFX.

EDIT: On 17548 there's also static, with the OpenSFX alpha as well as with the nightly.

It sounds like it's a problem of endianness. When the endianness of a sound file is interpreted the wrong way, it produces static which sounds like that.
Comment by frosch (frosch) - Wednesday, 16 September 2009, 18:28 GMT
There is at least one endian issue when loading them from file and later mixing multiple samples.

Maybe the output in the cocoa stuff needs another endian swap. Noone can tell.
Comment by swp (swp) - Wednesday, 16 September 2009, 18:33 GMT
Thanks, I will try that when I have time. Another clue for an endianness issue is Ingo von Borstel says it's running on his Intel Mac. Intel Core and PowerPC differ in the Endianness.
Comment by swp (swp) - Thursday, 24 September 2009, 11:47 GMT
This patch did the trick. I now hear the correct sound with OpenSFX. Thanks!

Loading...