OpenTTD

Tasklist

FS#3198 - [OSX] Could not get system colour space. You may need to calibrate your monitor.

Attached to Project: OpenTTD
Opened by tambarskjelve (torkil) - Sunday, 13 September 2009, 08:20 GMT
Last edited by Michael Lutz (michi_cc) - Sunday, 20 December 2009, 16:11 GMT
Type Bug
Category Core
Status Closed
Assigned To No-one
Operating System Mac OS X
Severity Medium
Priority Normal
Reported Version 0.7.2
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 1
Private No

Details

Playing OpenTTD on Leopard (OS 10.5) works nicely, but the exact same gamefiles on Snow Leopard (OS 10.6) do not work.

I should also say that my 10.5 machine is an old PowerBook, while the 10.6 machine is a Macbook Pro (not the newest kind, just an 2.5 GHz Intel Core 2 Duo).

I am no monitor calibration expert, but I think I have calibrated the monitor in the Screen settings panel, because my screen color profile says "Color-LCD calibrated".

Seems like some other people are also having the same issue here: http://www.tt-forums.net/viewtopic.php?f=31&t=44479
This task depends upon

This task blocks these from closing
 FS#2782 - [OSX] Port hopelessly outdated 
Closed by  Michael Lutz (michi_cc)
Sunday, 20 December 2009, 16:11 GMT
Reason for closing:  Fixed
Additional comments about closing:  (hopefully) in r18573. If that still fails, we are probably out of luck.
Comment by tambarskjelve (torkil) - Sunday, 13 September 2009, 08:21 GMT
Btw I have tried both 0.72 and Trunk versions of Open TTD, without luck.
I copied the gamefiles folder from one machine, where they were working, to the other, where they did not work, so I am certain the data files are there.
Comment by Remko Bijker (Rubidium) - Sunday, 13 September 2009, 11:39 GMT
Try changing the blitter to one of the 32 bpp blitters; probably it's "hardcoded" to a 8 bpp blitter in your config file.

Besides that, there is no official support for OS X 10.6.
Comment by tambarskjelve (torkil) - Sunday, 13 September 2009, 12:22 GMT
Small problem there... I am actually yet to locate the cfg-file. It is neither in my OpenTTD folder, in my Documents folder, or any of their subfolders.

On the bright side of things: After restarting my computer, the game now works! Yay!
Comment by Ingo von Borstel (planetmaker) - Wednesday, 16 September 2009, 21:54 GMT
I tried to reproduce this error by calibrating my monitor here but didn't run into this issue. But maybe the difference lies in the fact that mine is a macbook (on-board graphics) vs. a macbook pro (dedicated graphics card).
Comment by Michael Lutz (michi_cc) - Saturday, 17 October 2009, 22:39 GMT
This seems to be a spurious OS problem. Probably nothing OpenTTD can do about.
Comment by Tyler (tyler) - Saturday, 14 November 2009, 01:18 GMT
I did some research and it seems like TTD isn't the only project having problems like this – CMGetSystemProfile has been unreliable under Leopard and Snow Leopard for whatever reason. What this patch does is attempt to get the default colorspace if getting the system profile fails. Theoretically this will allow the app to run regardless.

As an aside, I think the colorspace thing definitely has to do with the graphics card - I was receiving the error on my MBP with the onboard card enabled, but when I switched to the dedicated card it went away.
Comment by Michael Lutz (michi_cc) - Saturday, 14 November 2009, 15:03 GMT
The patch does seem to make sense to me, but without having encountered the error myself, that's all I can say.

Loading...