OpenTTD

Tasklist

FS#2974 - trains unable to leave depot

Attached to Project: OpenTTD
Opened by Jan Kowalski (mike_123) - Thursday, 11 June 2009, 19:40 GMT
Last edited by Zdeněk Sojka (SmatZ) - Saturday, 13 June 2009, 10:22 GMT
Type Bug
Category Vehicles
Status Closed
Assigned To No-one
Operating System All
Severity Medium
Priority Normal
Reported Version 0.7.1
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

load game, join company #1, look at train #22 and his friends
(application/octet-stream)    asd.sav (258.3 KiB)
This task depends upon

Closed by  Zdeněk Sojka (SmatZ)
Saturday, 13 June 2009, 10:22 GMT
Reason for closing:  Fixed
Additional comments about closing:  r16571
Comment by Zdeněk Sojka (SmatZ) - Friday, 12 June 2009, 11:42 GMT
They will leave the depot if you move that 1x1 station somewhere else.
Comment by Zdeněk Sojka (SmatZ) - Friday, 12 June 2009, 12:53 GMT
Confirmed for 0.7.1, trunk doesn't have this issue.
Comment by Zdeněk Sojka (SmatZ) - Saturday, 13 June 2009, 08:40 GMT
The 0.7 branch broke by r16324 (between 0.7.1-RC1 and 0.7.1-RC2).
Comment by Zdeněk Sojka (SmatZ) - Saturday, 13 June 2009, 09:52 GMT
For Alberth, even trunk is broken (since r16322 - that one was backported to 0.7 in r16324).
Comment by Zdeněk Sojka (SmatZ) - Saturday, 13 June 2009, 10:12 GMT
Possible patch

Loading...