OpenTTD

Tasklist

FS#2871 - Non-stop not working for road vehicles

Attached to Project: OpenTTD
Opened by Ingo von Borstel (planetmaker) - Tuesday, 28 April 2009, 19:13 GMT
Last edited by Remko Bijker (Rubidium) - Wednesday, 29 April 2009, 21:12 GMT
Type Bug
Category Vehicles
Status Closed
Assigned To No-one
Operating System All
Severity Low
Priority Normal
Reported Version 0.7.0
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

In the attached savegame, join Ammler's company. Look at e.g. vehicle #6 (station Fonwood mines).
They drive on a linear road with the placement being Depot - Fonwood Mines - Beborough Bay Mines.
With orders like Full load at Fonwood, Transfer & leave empty at Beborough & visit depot for service
All orders are non-stop. Vehicles load coal before entering the depot, though.
This task depends upon

Closed by  Remko Bijker (Rubidium)
Wednesday, 29 April 2009, 21:12 GMT
Reason for closing:  Fixed
Additional comments about closing:  In r16187
Comment by Ingo von Borstel (planetmaker) - Tuesday, 28 April 2009, 19:15 GMT
The same behaviour can be seen in trunk r16157, too.
Comment by Remko Bijker (Rubidium) - Tuesday, 28 April 2009, 21:14 GMT
What's wrong?
Vehicle #6 of Ammlers company does:
- full load at fonwood mines (as per order)
- unload at beborough bay mines (as per orders)
- services at fonwood road depot (as per orders)
- returns towards fonwood mines, but breaks down at beborough bay mines (as per settings). After the vehicle being fixed it continues empty towards fonwood mines and the circle continues.

The in both r16120-0.7 and r16180.
Comment by Ammler (Ammler) - Tuesday, 28 April 2009, 22:01 GMT
Might not be clear: The going non-stop to depot order is for the Depot at Fonwood.
Comment by Ingo von Borstel (planetmaker) - Tuesday, 28 April 2009, 22:08 GMT
Look closely at the vehicles. They load already at Fonwood mines on their way to the depot. And then they go non-stop from the depot to Beborough bay mines to unload.
E.g. see in the attached screenshot vehicle #12 - it is already loaded when it leaves the depot. Vehicle #8 is loading (non-stop not working obviously for the depot order) and the other vehicles queuing behind it.
Comment by Remko Bijker (Rubidium) - Tuesday, 28 April 2009, 22:14 GMT
So the problem is not non-stop not working, but the depot order being 'seen' as fulfilled even when it reached another depot.
Comment by Ingo von Borstel (planetmaker) - Wednesday, 29 April 2009, 04:48 GMT
Oh yes, you're right. The problem is that the depot orders are seen as fulfilled even if a different(ly named) depot was / is used. It basically defies the purpose of the 'service order', if you play with breakdowns; in those cases you (or at least I) most often want the vehicle visit the depot you ordered it to visit.
OTOH I can imagine also situations where "visit any depot" instead of "visit this depot" is the better solution.
Comment by Ammler (Ammler) - Wednesday, 29 April 2009, 11:05 GMT
Goto nearest depot is for that purpose.

Workaround: Adding the other depot to the order list, too.

Loading...