OpenTTD

Tasklist

FS#2782 - [OSX] Port hopelessly outdated

Attached to Project: OpenTTD
Opened by Remko Bijker (Rubidium) - Wednesday, 01 April 2009, 10:15 GMT
Last edited by Michael Lutz (michi_cc) - Saturday, 17 October 2009, 22:38 GMT
Type Bug
Category Core
Status Closed
Assigned To No-one
Operating System Mac OS X
Severity Low
Priority Normal
Reported Version trunk
Due in Version Undecided
Due Date Undecided
Percent Complete 0%
Votes 1
Private No

Details

The OSX port is at least missing:
- entering of complex characters fails (Chinese, Japanese, CJK), fee  FS#2484 
Closed by  Remko Bijker (Rubidium)
Sunday, 22 August 2010, 20:26 GMT
Reason for closing:  Not a bug
Additional comments about closing:  Can't be bothered to update this anymore; just check "waiting for porter" stuff prefixed by [OSX].
Comment by Remko Bijker (Rubidium) - Friday, 28 August 2009, 20:20 GMT
macos.mm is an utter mess:
- it doesn't show NewGRFs when they exist, though it says there are no NewGRFs
- it doesn't show the right OSX version, even though there are ways to get the correct one
- it doesn't show all CPUs and in case of an unknown CPU is just says unknown instead of (also) giving the numeric value so we can look it up
- it doesn't comply with coding style in lots of places
- there are typos in the GUI strings, e.g. presists

The other files in os/macosx/ fail on coding style and sanity too!
Comment by Ingo von Borstel (planetmaker) - Sunday, 30 August 2009, 13:09 GMT
The attached patch generalizes and cleans up a bit the CPU detection by using the CPU tables in the available header files, after checking a range of CPUs more directly (as the CPU tables in the header files are not new...).

The patch could be made very small, if the first attempt to get a better CPU description is dropped; it would then condense to the part in GetProcessor() at the very bottom guarded by if (err) {...}

The patch builds upon the version detection patch http://bugs.openttd.org/task/3156/getfile/4663/fix_osxversion_detection_r17291.diff
Comment by Ingo von Borstel (planetmaker) - Sunday, 30 August 2009, 21:52 GMT
Attached updated patches for partially cleaning up src/os/macosx/macos.mm

1st part: version_detection.diff
2nd part: cputype.diff

3rd parg, still a TODO: adding the newgrf information as they obviously once were available. Are they actually in such case reported for other OS and where should I then look for that?
Comment by Ingo von Borstel (planetmaker) - Sunday, 30 August 2009, 22:12 GMT
Another update of the cputype diff, fixing further issues with comments in the code (and one left-over also from the version_detection).
Comment by Ingo von Borstel (planetmaker) - Sunday, 30 August 2009, 22:46 GMT
yet another iteration in small fixes, mainly thanks to Yexo pointing them out.
Comment by Ingo von Borstel (planetmaker) - Sunday, 30 August 2009, 22:53 GMT
and another one :-)
Comment by Thijs Marinussen (Yexo) - Sunday, 30 August 2009, 23:39 GMT
Some changes to apply to coding style (and removing some coding style fixing at places unrelated to those patches).
Comment by Ingo von Borstel (planetmaker) - Monday, 31 August 2009, 06:31 GMT
works for me. Attached another version of version_detection with yet another 4 lines of coding style improvements
Comment by Ingo von Borstel (planetmaker) - Friday, 04 September 2009, 18:50 GMT
following this days discussion, this is a leaner version of the MacOS version detection.
Comment by Michael Lutz (michi_cc) - Sunday, 20 September 2009, 18:15 GMT
 FS#3223  has a MIDI player implemented with CoreAudio, i.e. not using QuickTime.

I've also collected all the so far proposed OS X patches at:
http://www.icosahedron.de/cgi-bin/gitweb.cgi?p=ottd_osx.git
Comment by Michael Lutz (michi_cc) - Saturday, 26 September 2009, 22:02 GMT
The two attached patches try to improve the configure script with regards to the
minimal OSX version and the detection of the SDK and the usable features.

The second one applies on top of the first one. Especially the second one could use
testing with different options for the configure script. All optional features should
be properly detected, but maybe I missed something.

The git branch is updated as well.
Comment by Michael Lutz (michi_cc) - Sunday, 04 October 2009, 22:33 GMT
version_detection and the two configure patches are in trunk now.
CPU type was made obsolete by providing a implementation of the common CrashLog system.
Comment by Michael Lutz (michi_cc) - Saturday, 17 October 2009, 22:37 GMT
Automatic font detection is present since r17794.
Comment by Lauri Nurmi (ln) - Friday, 01 January 2010, 12:55 GMT
 FS#3194  and  FS#2585 , the two most important unfixed ones are both related to fullscreen video. I wonder if they could be fixed by using the Quartz video implementation in fullscreen too (now used only for window mode). It would also have some other advantages over the current implementation.

Loading...