OpenTTD

Tasklist

FS#251 - Profit from departure station - passangers

Attached to Project: OpenTTD
Opened by precision (precision) - Saturday, 22 July 2006, 09:48 GMT
Last edited by Darkvater (Darkvater) - Thursday, 02 November 2006, 15:52 GMT
Type Bug
Category Core
Status Closed
Assigned To No-one
Operating System All
Severity High
Priority Normal
Reported Version trunk
Due in Version 0.5.0
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Watch the train which makes profit at the station that it should take the passangers from.
This task depends upon

Closed by  Jonathan Coome (Maedhros)
Sunday, 03 December 2006, 23:02 GMT
Reason for closing:  Fixed
Additional comments about closing:  This has now been fixed as a side-effect of r7326 (gradual loading).
Comment by precision (precision) - Saturday, 22 July 2006, 13:02 GMT
Please correct "passangers" to passengers :)
Comment by precision (precision) - Tuesday, 25 July 2006, 12:38 GMT
The bug can be seen in r5600.
Comment by PandaMojo (PandaMojo) - Sunday, 20 August 2006, 02:56 GMT
Still in 5962 - occurs for any station that's being used as a feeder destination, and accepts the good being fed (I'm pretty sure anyways). Patch against 5962 attached, although this should be sanity checked by someone with a clue (tm) since this is my first patch here :). Seems to work here though, for both this savegame and some of my own affected bugs.
Comment by PandaMojo (PandaMojo) - Sunday, 20 August 2006, 03:28 GMT
Realized another probable bug in that patch. Fixing it.
Comment by PandaMojo (PandaMojo) - Sunday, 20 August 2006, 03:34 GMT
Posting the fixed patch in  FS#177  which this seems to be a duplicate of.
Comment by Darkvater (Darkvater) - Thursday, 02 November 2006, 15:51 GMT
Both related tasks,  FS#218  and  FS#177  contain savegames, screenshots and or a patch.

Please look in the 'related tasks' tab when fixing this bug.

Loading...