OpenTTD

Tasklist

FS#2403 - Refit order doesn't work when using 'going to nearest depot'

Attached to Project: OpenTTD
Opened by AnthonyVDG (avd) - Tuesday, 11 November 2008, 15:06 GMT
Last edited by Zdeněk Sojka (SmatZ) - Tuesday, 11 November 2008, 22:52 GMT
Type Bug
Category Vehicles
Status Closed
Assigned To No-one
Operating System All
Severity Low
Priority Normal
Reported Version 0.6.3
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

I've tried to use the order 'going to nearest depot' in combination with a refit order, but it doesn't work in r14572. I've tried to reproduce it too: if you use it with a specific depot it will work, but not if you use the nearest depot order...
This task depends upon

Closed by  Zdeněk Sojka (SmatZ)
Tuesday, 11 November 2008, 22:52 GMT
Reason for closing:  Fixed
Additional comments about closing:  In r14577. Thanks for nice report and help with fixing :-)
Comment by AnthonyVDG (avd) - Tuesday, 11 November 2008, 15:11 GMT
:/ forgot to change reported version into r14572
Comment by Ott (Antdovu) - Tuesday, 11 November 2008, 16:31 GMT
example of bug
Comment by Swallow (Swallow) - Tuesday, 11 November 2008, 17:24 GMT
The attached patch file should fix the problem
Comment by Zdeněk Sojka (SmatZ) - Tuesday, 11 November 2008, 19:34 GMT
The same applies to road vehicles, but the patch doesn't seem to fix it for them (though the code is shared). (I would like to hear I did the test wrongly, and this patch fixes the behaviour for RVs :)
Comment by Swallow (Swallow) - Tuesday, 11 November 2008, 20:48 GMT
I ran a quick test with road vehicles and everything seemed to work as it should. Are you sure you tested correctly?
Comment by frosch (frosch) - Tuesday, 11 November 2008, 21:19 GMT
yup, also works for me :)
Comment by Zdeněk Sojka (SmatZ) - Tuesday, 11 November 2008, 22:47 GMT
You made me happy, I tested it wrongly :-)
Attached is the testcase I used. The vehicles loses its "Going to nearest depot" status.

Loading...