OpenTTD

Tasklist

FS#192 - Assertion failed "load_index == SPR_CANALS_BASE"

Attached to Project: OpenTTD
Opened by attila (attila) - Monday, 29 May 2006, 07:34 GMT
Type Bug
Category Core
Status Closed
Assigned To No-one
Operating System Mac OS X
Severity Critical
Priority Normal
Reported Version 0.4.7
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

After downloading the Universal binary for Mac OS X, copying and appropriately renaming the required data files from a DOS version of TTD I had lying around (i.e. TRG1.GRF became trg1r.grf etc.), and attempting to launch it on a iMac G5, it fails with the following message:

An assertion has failed and OpenTTD must quit.
LoadSpriteTables in gfxinit.c (line 352)
"load_index == SPR_CANALS_BASE"

Marked it as "critical" as it pretty much prevents me from starting the game in the first place.
This task depends upon

Closed by  Celestar (Celestar)
Friday, 02 June 2006, 14:16 GMT
Reason for closing:  Not a bug
Comment by attila (attila) - Monday, 29 May 2006, 08:55 GMT
Ok, a friend of mine helped me out with files from his copy of TTD deluxe for Windows, so that fixed my problem. I suspect there's some problem with handling the files from the DOS version of TTD...
Comment by Loïc GUILLOUX (glx) - Wednesday, 31 May 2006, 13:56 GMT
You don't need to rename DOS TTD files because OpenTTD knows what to do with them.

Loading...