OpenTTD

Tasklist

FS#1883 - Timetabling incorrect for aircraft

Attached to Project: OpenTTD
Opened by JCM (JCM) - Friday, 28 March 2008, 14:00 GMT
Type Bug
Category Vehicles
Status Closed
Assigned To No-one
Operating System All
Severity Low
Priority Normal
Reported Version 0.6.0-RC1
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Hi,

I have noticed that the 'timetabling' for aircraft is incorrect.
When using Autofill to generate the timetable for the first time, the days that are set are double that of the actual transit time.
In addition, the way that the system is checking for on-time performance is also doubled.

This happens regardless of the 'Plane Speed Factor' under Vehicles Patch Configuration (whether this is 1/1, 1/2, 1/3, 1/4 the problem is the same).

For example, if a plane takes off on Jun 1 and gets to its destination at Aug 1 (30 days), the Autofill will put in 60 days for the duration.
If I manully change the time to be 30 which is correct, the vehicle will then be running 30 days late for each leg (as it will record it as taking 60 days).
This is only a problem for aircraft - for trains and buses it works correctly.

I first noticed this problem in the 6.0 Beta 5 and see that it is still occurring in the 0.6 RC1.

regards
JCM.
This task depends upon

Closed by  Remko Bijker (Rubidium)
Friday, 28 March 2008, 18:42 GMT
Reason for closing:  Fixed
Additional comments about closing:  In r12477.
Comment by JCM (JCM) - Friday, 28 March 2008, 14:02 GMT
sorry there is a typo in my example - I meant takes off July 1 and arrives Aug 1.
(I know it is not 30 days between Jun 1 and Aug 1) !!

Loading...