OpenTTD

Tasklist

FS#1867 - Terrain under bridge over water bug

Attached to Project: OpenTTD
Opened by Trond (Trond) - Thursday, 20 March 2008, 07:34 GMT
Type Bug
Category Bridge
Status Closed
Assigned To No-one
Operating System Windows
Severity Low
Priority Normal
Reported Version trunk
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

r12289, never seen this one before, but I hardly ever build bridges, and especially not the cheap ones. Seems there is a terrain bug under this bridge, and I havent seen it on other bridges in this game. I do have some patches on this dev, but none that messes with terrain nor bridges. Also no grf files for bridges. Gonna try to build another similar bridge beside this and see if I can recreate the bug...
This task depends upon

Closed by  Peter Nelson (peter1138)
Thursday, 20 March 2008, 08:04 GMT
Reason for closing:  Invalid
Comment by Trond (Trond) - Thursday, 20 March 2008, 07:36 GMT
Doesnt happen with other bridges, but building a similar bridge besides this gives the same bug.
Comment by Peter Nelson (peter1138) - Thursday, 20 March 2008, 07:44 GMT
Can you reproduce this in trunk?
Comment by Peter Nelson (peter1138) - Thursday, 20 March 2008, 07:46 GMT
Actually it looks like its a 32bpp sprite replacing the pillars of the bridge...
Comment by Trond (Trond) - Thursday, 20 March 2008, 07:56 GMT
Couldnt reproduce it in 0.6.0.beta5, so I guess eather the bug is already fixed or it is caused by one of the patches. I do have a few 32bit tar's in the game, but I dont *think* any of those is messing with groundsprites nor bridges. Anyways, seems this one can just be closed then...

Loading...