OpenTTD

Tasklist

FS#1819 - one way road no longer one way after track built across

Attached to Project: OpenTTD
Opened by zothar (zothar) - Friday, 29 February 2008, 23:51 GMT
Type Bug
Category Core
Status Closed
Assigned To No-one
Operating System All
Severity Low
Priority Normal
Reported Version 0.6.0-beta4
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

reproduce by building a straight road piece across a tile, use the "one way roads" tool to make the road on the tile one way, build a piece of track across the road in the tile as a crossing and note that the directional arrow disappears, remove the track and the directional arrow is still gone. It doesn't appear that a competitor can remove the directional arrow from a one way road in a multiplayer game, but they can using this method. Either the UI is inconsistent between same and other players for removing the directional arrow, or the track laying removing the directionality is a bug.
This task depends upon

Closed by  Peter Nelson (peter1138)
Monday, 03 March 2008, 19:15 GMT
Reason for closing:  Fixed
Additional comments about closing:  In r12329
Comment by Manuel Wolf (Roujin) - Saturday, 01 March 2008, 23:22 GMT
Confirmed for current trunk (r12322).
Now how to address this? I suggest to add one-way support for level crossings. m5 bits 4 and 5 are still free for level crossings, these are the two bits that store one way information for normal roads.

If this were implemented, the abuse described here would not be possible since the one way arrow would stay on laying the track, and also when removing the track the arrow would still be there.
Comment by Zdeněk Sojka (SmatZ) - Saturday, 01 March 2008, 23:27 GMT
The behaviour is intended. It is not possible to draw a oneway sign over the crossing sprite (with custom grfs it looks even uglier).
Comment by Manuel Wolf (Roujin) - Saturday, 01 March 2008, 23:43 GMT
Where does this limitation come from? Couldn't it be fixed somehow? Should we accept this possible abuse in multiplayer games rather than keep the road oneway even if the oneway sign is not drawn?
Comment by Manuel Wolf (Roujin) - Sunday, 02 March 2008, 18:58 GMT
Okay, after talking to smatz yesterday, I know that it's agreed on that there are no one way roads allowed on crossings.
So then the other solution for this bug - disallow laying track on one way road.
Comment by Manuel Wolf (Roujin) - Sunday, 02 March 2008, 19:22 GMT
This should do the job...

Loading...