OpenTTD

Tasklist

FS#1733 - Paused game because of missing newgrfs, gets unintentionally unpaused

Attached to Project: OpenTTD
Opened by frosch (frosch) - Friday, 01 February 2008, 10:43 GMT
Type Bug
Category Core
Status Closed
Assigned To No-one
Operating System All
Severity Low
Priority Normal
Reported Version trunk
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

To reproduce:
- Load a game that will get paused because of missing newgrfs.
- Open again the 'load game' dialog from the menu.

This will cause unpausing the game. (Normally game is paused when opening that dialog).

The culprit seams to be the magic around _pause_game.
- Positive values are for paused games.
- Zero is for unpaused games.
- Negative values are for paused games because of missing/incompatible newgrfs.

Opening the 'load game' dialog causes _pause_game to get incremented (normally pauses the games), but because of the negative values it is actually unpaused.

There seems to be a bit more magic around, which I do not understand. (the comments say something about special pause for converting multiplayer to singleplayer)
This task depends upon

Closed by  Peter Nelson (peter1138)
Tuesday, 04 March 2008, 12:15 GMT
Reason for closing:  Fixed
Additional comments about closing:  In r12336

Loading...