OpenTTD

Tasklist

FS#1698 - symbol b9 is not displayed correctly

Attached to Project: OpenTTD
Opened by George (George) - Friday, 25 January 2008, 07:59 GMT
Last edited by Peter Nelson (peter1138) - Friday, 25 January 2008, 09:51 GMT
Type Bug
Category NewGRF
Status Closed
Assigned To No-one
Operating System Windows
Severity Medium
Priority Normal
Reported Version 0.6.0-beta3
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

ECS Power Plant has a ? symbol in industry window, while in TTDp it has <sup>-1</sup> symbol
The line's definition is
298 * 77 04 0A FF 01 DF D0 90 "Production: " 7B " MWh" B9 " (" 7B " MWh" B9 ")" 0D
"Level: " 7C "% (" 80 "), Remain: " 7C " months (0-undef)" 00
This task depends upon

Closed by  Peter Nelson (peter1138)
Friday, 25 January 2008, 13:49 GMT
Reason for closing:  Fixed
Additional comments about closing:  In r11981
Comment by Peter Nelson (peter1138) - Friday, 25 January 2008, 08:37 GMT
B9 should actually be a superscript 1, not -1, and neither TTD, TTDPatch nor OpenTTD's base graphics contain a superscript -1 symbol. I suppose TTDPatch is using the small font for it.

If you were to define it with action 12 the correct codepoints are 207B (superscript minus) and 00B9 (superscript one).
Comment by George (George) - Friday, 25 January 2008, 09:12 GMT Comment by Peter Nelson (peter1138) - Friday, 25 January 2008, 09:13 GMT
Hmm, wrong, it is there at B9... Therefore there is no particular reason it shouldn't be shown.
Comment by George (George) - Friday, 25 January 2008, 09:23 GMT
Do you need a screen shot of "?" symbol
Comment by Peter Nelson (peter1138) - Friday, 25 January 2008, 09:30 GMT
No, it looks like someone decided it doesn't need to be loaded... -1 is at sprite 155 in trg1r.pcx which is skipped for some reason...
Comment by George (George) - Friday, 25 January 2008, 09:45 GMT
Does it mean the bug is confirmed? :)
Comment by Peter Nelson (peter1138) - Friday, 25 January 2008, 09:50 GMT
Well, it's still the wrong symbol for B9, but we can probably handle that when translating codes. Maybe...

Loading...