OpenTTD

Tasklist

FS#1627 - Crash: Disconnecting road vehicle.

Attached to Project: OpenTTD
Opened by zyxist (zyxist) - Monday, 07 January 2008, 16:31 GMT
Last edited by Jean-Francois Claeys (Belugas) - Friday, 11 January 2008, 03:10 GMT
Type Bug
Category Vehicles → Trams
Status Closed
Assigned To No-one
Operating System All
Severity High
Priority Normal
Reported Version 0.6.0-beta1
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

While playing the newest OpenTTD beta, I encountered the following game crash:

*** OpenTTD Crash Report ***
Date: 2008-01-07 14:39:20
Build: 0.6.0-beta2 built on Dec 9 2007 22:47:34
Reason: !Disconnecting road vehicle.
Exception C0000005 at 00423885

I built a new tram line and sent the first vehicle. The vehicle stopped in a tram stop, because I forgot to add some rail to turn back. I added them, the tram turned back and as he reached first or second curve, the grame crashed. I tried the game from autosave and I did not build this line. It helped.
This task depends upon

Closed by  Remko Bijker (Rubidium)
Saturday, 12 January 2008, 22:09 GMT
Reason for closing:  Fixed
Additional comments about closing:  In r11825.
Comment by Jean-Francois Claeys (Belugas) - Monday, 07 January 2008, 16:32 GMT
Could you try the same behaviour with a nightly? I'm sure it has been fixed already
Comment by Remko Bijker (Rubidium) - Wednesday, 09 January 2008, 22:47 GMT
Furthermore we need a savegame from before the vehicle is splitting up, otherwise we cannot tell whether the bug still occurs or not.
Comment by Zdeněk Sojka (SmatZ) - Saturday, 12 January 2008, 20:57 GMT
The bug is reproducable - see attached savegame

Loading...