OpenTTD

Tasklist

FS#1616 - Crash when laying bridge

Attached to Project: OpenTTD
Opened by Bloodnok (Bloodnok) - Thursday, 03 January 2008, 14:10 GMT
Last edited by Remko Bijker (Rubidium) - Sunday, 06 January 2008, 16:12 GMT
Type Bug
Category Bridge
Status Closed
Assigned To No-one
Operating System Windows
Severity High
Priority Normal
Reported Version 0.6.0-beta1
Due in Version 0.6.0
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

I tried to lay a 2 square long concrete suspension bridge (50mph limit) in a town, over a blank space in the ground.
I was later planning to lay railway lines through under the bridge, but had not done so yet.
This is in 0.6.0-beta2, and I had the following .GRF files loaded (mostly from Pikkabird) in my newGRF section:

[newgrf]
ukwaypointsw.grf
pb_viaduct.grf
pikkindw.grf
pikbrikw.grf
pb_av8w.grf = 1
pb_hovs_bus.grf
pb_ukrs.grf
ukrsap1w.grf

I had laid a similar bridge a couple of squares down already. When I tried to place this one, the game instantly crashed, giving me the attached report.

HTH

James
This task depends upon

Closed by  Loïc GUILLOUX (glx)
Wednesday, 09 January 2008, 17:47 GMT
Reason for closing:  Fixed
Additional comments about closing:  In r11795.
Comment by Bloodnok (Bloodnok) - Thursday, 03 January 2008, 15:19 GMT
Okay, having re-loaded the savegame, it turns out that I had laid one of the two squares with track. Oh well...
Comment by Jean-Francois Claeys (Belugas) - Thursday, 03 January 2008, 15:21 GMT
could you post a savegame/screenshot from just before?
Comment by Bloodnok (Bloodnok) - Thursday, 03 January 2008, 15:36 GMT
This is as best I can do as a 'before' save - it's before I started preparing Sardwood for it's station though.
The crash save seems to have produced the landscape accurately pre-bridge. The screenshot shows where I attempted to lay it. I can't remember (sorry) whether I layed it from bottom right to top left or vice versa.

I'll start a new game and see if I can reproduce it in a smaller, cleaner environment.

HTH

James
Comment by Bloodnok (Bloodnok) - Thursday, 03 January 2008, 15:53 GMT
Okay, now reproduced, here's a save immediately before laying the bridge. It's repeatable (for me) - it crashes every time I try. It doesn't matter whether I start on the angled square with the tree and end where the half-road is, or start at the half-road and end up on the angled square with the tree. Previous screenshot should help with the placing - it's the same spot.

Hopefully this is a bit more useful than the last one :-)

HTH

Loading...