OpenTTD

Tasklist

FS#1605 - Feature: Patch setting for enable/disable Tree growth

Attached to Project: OpenTTD
Opened by Frostregen (Frostregen) - Sunday, 30 December 2007, 18:59 GMT
Last edited by Zdeněk Sojka (SmatZ) - Thursday, 11 June 2009, 00:05 GMT
Type Patch
Category Core
Status Closed
Assigned To No-one
Operating System All
Severity Low
Priority Normal
Reported Version trunk
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

revision 11722

This adds a patch-setting for enabling/disabling Tree Growth.
Savegame version is bumped to 84.

If the patch is active it disables the "OnTick_Trees" completely,
and "TileLoop_Trees" partly. (Grass still grows beneath trees)

This may be useful to prevent trees from filling the whole map,
or for scenario's where nice forests are wanted.
This task depends upon

Closed by  Zdeněk Sojka (SmatZ)
Thursday, 11 June 2009, 00:05 GMT
Reason for closing:  Won't implement
Additional comments about closing:  You can switch to invisible trees. When trees don't grow, there won't be any if you demolish them. Also, it's not realistic ;-)
Comment by Frostregen (Frostregen) - Sunday, 30 December 2007, 19:02 GMT
minor coding style fix.
Comment by Frostregen (Frostregen) - Sunday, 30 December 2007, 19:40 GMT
again, coding style fix
Comment by Frostregen (Frostregen) - Sunday, 30 December 2007, 20:06 GMT
simplified code. (patchfile is more readable now)
Comment by Frostregen (Frostregen) - Friday, 11 January 2008, 11:28 GMT
added patchsetting: "Disable Tree grow in scenario editor",
which is a config setting only -> not saved with map.
synced with trunk r11811
Comment by Ingo von Borstel (planetmaker) - Thursday, 29 May 2008, 22:16 GMT
updated to r13305
Comment by Ingo von Borstel (planetmaker) - Thursday, 12 June 2008, 06:52 GMT
updated, simplified a lot and fixed coding style (actually by Belugas)
Comment by Benedikt Brüggemeier (skidd13) - Thursday, 12 June 2008, 14:38 GMT
The main problem with this patch is that some industries depend on tree growth, like lumber mills in tropic. And additionaly such industries can be defined via GRF, so the patch breaks current functionality. At it's current design the patch wont make it into trunk.
Comment by Jean-Francois Claeys (Belugas) - Thursday, 12 June 2008, 14:49 GMT
I can confirm that.
You can use it for patch packs, it's ok since it's "network" friendly, but it willnot make it in trunk because of the above reasons. And Planetmaker himself is aware of the reasons.
Comment by Frostregen (Frostregen) - Thursday, 12 June 2008, 17:37 GMT
In theory we could check for a nearby industry which depends on tree-growth, and allow those trees to grow anyway.
In practice this check could be quite a slowdown with many trees.

Maybe the other way round?
Industries let the trees grow around them? (Only if this patchsetting is enabled)

Loading...