OpenTTD

Tasklist

FS#1577 - map generation hangs with alpine grf

Attached to Project: OpenTTD
Opened by Johannes E. Krause (Eddi) - Saturday, 22 December 2007, 18:46 GMT
Last edited by Remko Bijker (Rubidium) - Sunday, 30 December 2007, 09:54 GMT
Type Bug
Category NewGRF
Status Closed
Assigned To No-one
Operating System All
Severity Low
Priority Normal
Reported Version trunk
Due in Version 0.6.0
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

generating an arctic map hangs when the alpine grf is loaded

problem disappears if i remove my .cfg file

revision is 11680, but problem existed already around release of 0.6.0beta1
This task depends upon

Closed by  Remko Bijker (Rubidium)
Monday, 31 December 2007, 07:14 GMT
Reason for closing:  Fixed
Additional comments about closing:  In r11728.
Comment by Antti Silventoinen (as) - Tuesday, 25 December 2007, 10:44 GMT
I did some testing with this in r11689. It looks like chrash depends on starting year.
If I start in year 1929 or earlier the game hangs during map generation.
If I start it 1930 or later it works correctly, except that buildings above snowline don't have snowy graphics.
Comment by Antti Silventoinen (as) - Tuesday, 25 December 2007, 21:09 GMT
More testing: r11424 is last version that works correctly, so r11425 seems to have broken sommething.
Comment by Remko Bijker (Rubidium) - Saturday, 29 December 2007, 22:25 GMT
I cannot reproduce it with the given config file at r11720.
Comment by Johannes E. Krause (Eddi) - Sunday, 30 December 2007, 01:06 GMT
i can still reproduce it in r11721, like as did

use default config
load alpinew.grf
set start year < 1930
start arctic game
game hangs during map generation
Comment by Jean-Francois Claeys (Belugas) - Sunday, 30 December 2007, 03:34 GMT
Seems to be related somehow in the GrowTown function, although i cannot trace exactly where and when nor why
Comment by Remko Bijker (Rubidium) - Sunday, 30 December 2007, 21:12 GMT
The problem is that there are, for some reason, no houses pre 1930. So trying to build a house fails horribly.

Loading...