OpenTTD

Tasklist

FS#1569 - Wrong inaugurate date

Attached to Project: OpenTTD
Opened by Draakon (Draakon) - Monday, 17 December 2007, 15:52 GMT
Type Bug
Category Core
Status Closed
Assigned To No-one
Operating System Windows
Severity Low
Priority Normal
Reported Version trunk
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

As you can see from the picture below, current date is very different(1930 is the start date for that scenario i am playing on) from inaugurate date and i included cheat menu too to show i haven't cheated. I am using r11601. How to reproduce: load a TTD or TTDP(how to load TTDP scenario on OpenTTD: load TTDP scenario, deselect all newgrfs, if any, apply and save, should work then)Scenarios and set start date below 1950. Then if you save the scenario and go and play inaugurate is different from start date.
This task depends upon

Closed by  Jean-Francois Claeys (Belugas)
Friday, 28 December 2007, 04:23 GMT
Reason for closing:  Fixed
Additional comments about closing:  in r11714.
Although, do not try to load a scenario with the command line option -g, as this portion of the game will not be protected yet.
I'll try to find a way, but i'm not sure it can easily be done.
And i've got other things to do too
Comment by Jean-Francois Claeys (Belugas) - Monday, 17 December 2007, 18:07 GMT
Any grf involved? If so, please provide the list.
Thanks
By the way, did you said the scenario was from TTD or TTDP? Not from OTTD?
Comment by Draakon (Draakon) - Monday, 17 December 2007, 18:10 GMT
TTP
grfs in the picture.
Comment by Draakon (Draakon) - Monday, 17 December 2007, 18:11 GMT
sry typo, i meant TTDP
Comment by Jean-Francois Claeys (Belugas) - Monday, 17 December 2007, 18:12 GMT
Any idea from which grf that vehicle was coming from?
Comment by Draakon (Draakon) - Monday, 17 December 2007, 18:14 GMT
what vehicle? :S
Comment by Jean-Francois Claeys (Belugas) - Monday, 17 December 2007, 18:15 GMT
The one with the wrong introduction date...
vehicle = truck/buss
Comment by Draakon (Draakon) - Monday, 17 December 2007, 18:16 GMT
if you mean in the Company Info window, then it should be Long Vehicles V4
Comment by Jean-Francois Claeys (Belugas) - Monday, 17 December 2007, 18:17 GMT
ho... sorry... you are right... forget me
/me should not read emails when on a hurry :S
Comment by Draakon (Draakon) - Monday, 17 December 2007, 18:19 GMT
lol i forgive you, but still a nice effect :P
Comment by Jean-Francois Claeys (Belugas) - Monday, 17 December 2007, 18:54 GMT
Could you post the offending scenario? I tried to duplicate, but all the sceanrios i made coming form ttdp are not doing what you've shown.
Sadly.
Comment by Remko Bijker (Rubidium) - Monday, 17 December 2007, 21:15 GMT
Let me guess... the scenario made in TTDP already contains a company, so no new company is made and the inauguration date is coming straight from the scenario.
Comment by Draakon (Draakon) - Tuesday, 18 December 2007, 14:09 GMT
These are the scenarios i am talking about.

Rubidium, no they don't contain any company.
Comment by Remko Bijker (Rubidium) - Tuesday, 18 December 2007, 18:49 GMT
Actually they do; only the company has not built a thing, but there is an 'active' player. The easiest way to 'show' that this is true is by opening Totally Texas.scn in the scenario editor, click on the button of the landscaping tool, click on reset landscape. Then save the scenario. When you then load that scenario you will see that the inauguration date is correct.
Comment by Draakon (Draakon) - Wednesday, 19 December 2007, 08:00 GMT
Then how come for trt07.ss0 is it wrong? Its original TTD(it comes with it) and no company is there.
Comment by Remko Bijker (Rubidium) - Wednesday, 19 December 2007, 10:09 GMT
Because it has the same kind of 'company' as the Texas scenario has. I don't know whether this always happens in TTD scenario or that it the scenario is made in TTDP or that it is even a converted TT savegame.
Comment by Draakon (Draakon) - Wednesday, 19 December 2007, 19:23 GMT
it is a scenario that comes when you buy TTD aka its not made in TTDP or OpenTTD

Loading...