OpenTTD

Tasklist

FS#1541 - Follow for vehicle, when sell it

Attached to Project: OpenTTD
Opened by Fragster (Fragster) - Thursday, 13 December 2007, 09:19 GMT
Type Bug
Category Core
Status Closed
Assigned To No-one
Operating System All
Severity Low
Priority Normal
Reported Version trunk
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

If we turn smooth scrolling on, then use CTRL+location button in vehicle window to track it's way, then send to depot & sell it without turning of tracking - viewport will jumping over the map randomly
This task depends upon

Closed by  Remko Bijker (Rubidium)
Friday, 14 December 2007, 21:11 GMT
Reason for closing:  Fixed
Additional comments about closing:  In r11632.
Comment by Remko Bijker (Rubidium) - Thursday, 13 December 2007, 10:11 GMT
What version are you using?
Comment by Fragster (Fragster) - Thursday, 13 December 2007, 10:28 GMT
lastest nightly on today. In 0.6.0 it also presents.
For example with train 73 in save - it works... It must be many vehicles in game
Comment by Fragster (Fragster) - Thursday, 13 December 2007, 10:31 GMT
r11625
Comment by Benedikt Brüggemeier (skidd13) - Thursday, 13 December 2007, 12:40 GMT
Ok. I can reproduce this behavior.

Guide how you can reproduce:
1. start a new game
2. build a rail-depot somewhere and build an engine in it
3. start this engine
4. build a rail-depot elsewhere on the map and build an engine in it
5. connect viewport to engine #2
6. delete engine #2

Now you will be moved to engine #1.
Comment by Fragster (Fragster) - Thursday, 13 December 2007, 13:04 GMT
in may game with train #73 viewport moves not to other vehicles, but in very strange ways... I think, that the reason is pointer to train, which is deleted, & memory filled with other data... in skidd13's сфыу - it is just other train...
Comment by Fragster (Fragster) - Thursday, 13 December 2007, 13:04 GMT
«in skidd13's сфыу » is «in skidd13's case»

Loading...