OpenTTD

Tasklist

FS#1521 - Build when paused - scenario editor

Attached to Project: OpenTTD
Opened by Moriarty (Moriarty) - Saturday, 08 December 2007, 12:44 GMT
Last edited by Remko Bijker (Rubidium) - Tuesday, 07 December 2010, 21:13 GMT
Type Feature Request
Category Interface
Status Closed
Assigned To Zdeněk Sojka (SmatZ)
Operating System All
Severity Very Low
Priority Normal
Reported Version trunk
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 3
Private No

Details

Maybe not a bug, but for some reason build-when-paused isn't enabled by default in the scenario editor (r11588) .
This task depends upon

Closed by  Remko Bijker (Rubidium)
Tuesday, 07 December 2010, 21:13 GMT
Reason for closing:  Implemented
Additional comments about closing:  In r21429
Comment by Remko Bijker (Rubidium) - Saturday, 08 December 2007, 12:49 GMT
That's because it is a cheat and enabling it would show that as you being a cheater even when you haven't cheated in-game.
Comment by Moriarty (Moriarty) - Sunday, 09 December 2007, 14:30 GMT
So molding the landscape for free, building new industries for free and generally being god is fine (that's what the scenario editor does), but "building while paused" is a "cheat"? That's why I reported it as a bug - it's very ... inconsistant.
Comment by Zdeněk Sojka (SmatZ) - Monday, 10 December 2007, 19:40 GMT
It IS consistent. You cannot do anything while the game is paused - no matter if you are in game editor or in normal game.

However, there may be changes in the pause mode, so I am assigning this task to me.
Comment by Jean-Francois Claeys (Belugas) - Monday, 10 December 2007, 19:50 GMT
I agree with Smatz. It is consistent. Plus the time is actually frozen in scenario mode. The tile processing is on (which is not the case in normal mode) but time does not increment. And that is what is the more important thing here. Build-When-Paused freezes the tile-processing. This is not the same status as in scenario mode.
Comment by Bilbo (bilbo) - Monday, 30 March 2009, 17:00 GMT
Attaching simple patch that fixes it - if in editor, you can build even while paused (and without marking you as a cheater). In the game nothing changes (build in pause only as a cheat)

Building while paused eats less CPU time (since the tile processing is OFF), which may be useful for large maps and computers that are either slow or that have very noisy fans that power up once the CPU usage is too high (most notebooks, including mine)

With 2048*2048 map, openttd eats about 15% CPU time when doing nothing in editor and only 2% when paused (Athlon 3000).
Comment by Bilbo (bilbo) - Wednesday, 14 April 2010, 12:25 GMT
Update of this patch to 19627 due to minor change in trunk. Functionality unchanged.
Comment by Bilbo (bilbo) - Wednesday, 14 April 2010, 12:52 GMT
Accidentally attached broken file, this one is correct.

Loading...