OpenTTD

Tasklist

FS#152 - Chrash Report

Attached to Project: OpenTTD
Opened by brygge_2 (brygge_2) - Thursday, 04 May 2006, 12:42 GMT
Type Bug
Category Vehicles → YAPF
Status Closed
Assigned To KUDr (KUDr)
Operating System Windows
Severity High
Priority Normal
Reported Version YAPF branch (dev)
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

I was playing with the "norev000 built on Sun Apr 30 10:13:23 2006" and then when i was about to flatten land it generated this chrash report:
*** OpenTTD Crash Report ***
Date: 2006-05-04 14:13:28
Build: norev000 built on Sun Apr 30 10:13:23 2006
Exception C0000005 at 0043E461
Registers:
EAX: 019AA000 EBX: 00000003 ECX: 00000001 EDX: 00000000
ESI: 00000001 EDI: 00000002 EBP: 0057BDE4 ESP: 0012FC98
EIP: 0043E461 EFLAGS: 00210246

Bytes at CS:EIP:
0F B6 B0 F8 68 57 00 C1 E6 10 81 C6 EB 02 07 03 81 CE 00 80 00 00 E8 24

Stack trace:
00000001 00441135 00000016 00577BA4 000000A2 00000280 0012FCF0 00000000
00000008 004390E2 00000001 00000016 0012FD08 00577BA4 0043905A 00000000
004390B7 00000001 00000068 00577BAC 00000000 000000C0 0012F000 00577BA4
00438F73 00000000 000000C0 00000068 00000000 000000A2 019A6EA2 00000000
00000000 0000001E 00000052 00000500 00400000 0040CB00 000000A2 00000000
00000068 004FC823 00000000 000000C0 0040CC05 000000A2 00000040 00577AE0
0012FD84 00577AE0 00000080 004FC822 00000500 000003C8 00000014 0043AAE3
77D3E655 0008C3F3 77F159A0 77D3C96C 00438C8D 0012FE10 FFFFFFFF 00000001
00000001 0008C3F3 00090132 00000201 00000001 000E00B0 0008C3B6 000000B0
00000037 004214E6 00000A28 00000001 0012FFC0 00000001 00003528 00000000
00000000 00000000 00000000 00000000 00000001 7C90E027 7C913900 FFFFFFFF
00000024 0012FE08 00000000 00000000 216133CB 0012FE18 7C8103A4 FFFFFFFF
0012FE30 004EFB94 00000000 004371BA 00000002 00152311 7C919AEB 004B4320
00000002 0000FFFF 7FFDF000 00252590 B7B6B5B4 00B03510 7C9131DC 00000011
0012FF28 40000000 00000004 0012FE7C 0012FE7C 00000000 00B03D10 00B00164
00000000 00B03D18 00000000 0012FEC8 004AB965 00B00000 00000000 004AB96E
C311F49F 7C90E027 7C91392E FFFFFFFF 00000024 0012FEB8 00000004 00000000
216133CB 00000004 004A53F3 00B03D1C 004A6EF1 004A6E3E 21D10ED7 0012FF14
0012FF14 004A560B 00000000 00000000 0012FF04 004A5616 0012FF04 0049E9BF
00152334 004AC72E 00000000 004F6D30 00B02B40 00B01E90 004A2C01 0012FFC0
004AC77D 00000000 00000022 00000000 00000004 004A19FF 00400000 00000000
00152336 00000001 C311F597 00370036 00370034 7FFD5000 00000044 00154268
001544F8 00154510 00000000 00000000 00000000 00000000 00000000 00000000
00000000 00000C01 00000001 00000000 00000000 00010001 00000000 C0000005

Module information:
D:ProgramfilerOpenTTDopenttd.exe handle: 00400000 size: 1064448 crc: CD61D762 date: 2006-05-01 18:24:54
C:WINDOWSsystem32ntdll.dll handle: 7C900000 size: 704000 crc: B5AEB8B3 date: 2004-08-04 12:00:00
C:WINDOWSsystem32kernel32.dll handle: 7C800000 size: 984576 crc: D3282E32 date: 2004-08-04 12:00:00
C:WINDOWSsystem32WINMM.dll handle: 76B30000 size: 175104 crc: 3AF912F8 date: 2004-08-04 12:00:00
C:WINDOWSsystem32USER32.dll handle: 77D30000 size: 577024 crc: F05B9759 date: 2005-03-02 18:19:19
C:WINDOWSsystem32GDI32.dll handle: 77F10000 size: 280064 crc: 1E4FCD55 date: 2005-12-29 02:56:08
C:WINDOWSsystem32ADVAPI32.dll handle: 77DC0000 size: 679936 crc: 3B1B6F8D date: 2004-08-04 12:00:00
C:WINDOWSsystem32RPCRT4.dll handle: 77E70000 size: 581120 crc: 2116FEE8 date: 2004-08-04 12:00:00
C:WINDOWSsystem32WS2_32.dll handle: 71AA0000 size: 82944 crc: AFE85148 date: 2004-08-04 12:00:00
C:WINDOWSsystem32msvcrt.dll handle: 77C00000 size: 343040 crc: B905DCC6 date: 2004-08-04 12:00:00
C:WINDOWSsystem32WS2HELP.dll handle: 71A90000 size: 19968 crc: D91B9DD6 date: 2004-08-04 12:00:00
C:WINDOWSSm9hY2hpbSBSZWllcnNlbgasappsrv.dll handle: 00B30000 size: 187904 crc: E067CBF0 date: 2005-08-02 15:46:54
C:WINDOWSsystem32comctl32.dll handle: 5D5D0000 size: 611328 crc: DF44F740 date: 2004-08-04 12:00:00
C:WINDOWSsystem32oleaut32.dll handle: 77110000 size: 553472 crc: 8BE269CB date: 2004-08-04 12:00:00
C:WINDOWSsystem32ole32.dll handle: 774D0000 size: 1284608 crc: A887C0BC date: 2005-07-26 04:43:13
C:WINDOWSsystem32version.dll handle: 77BF0000 size: 18944 crc: 01B8D673 date: 2004-08-04 12:00:00
C:WINDOWSsystem32WINTRUST.dll handle: 76C20000 size: 176640 crc: 3A44BBAF date: 2004-08-04 12:00:00
C:WINDOWSsystem32CRYPT32.dll handle: 77A70000 size: 598528 crc: B57BFED9 date: 2004-08-04 12:00:00
C:WINDOWSsystem32MSASN1.dll handle: 77B10000 size: 57344 crc: D06FFB08 date: 2004-08-04 12:00:00
C:WINDOWSsystem32IMAGEHLP.dll handle: 76C80000 size: 144384 crc: E1A7E438 date: 2004-08-04 12:00:00
C:WINDOWSsystem32wdmaud.drv handle: 72CF0000 size: 23552 crc: C130F0FC date: 2004-08-04 00:03:42
C:WINDOWSsystem32msacm32.drv handle: 72CE0000 size: 20480 crc: 52BC6A6F date: 2004-08-04 12:00:00
C:WINDOWSsystem32MSACM32.dll handle: 77BD0000 size: 71680 crc: B0433EA6 date: 2004-08-04 12:00:00
C:WINDOWSsystem32midimap.dll handle: 77BC0000 size: 18944 crc: 2BDB6302 date: 2004-08-04 12:00:00
C:WINDOWSsystem32uxtheme.dll handle: 5B290000 size: 218624 crc: 7A5ADD1B date: 2004-08-04 12:00:00
C:WINDOWSsystem32CLBCATQ.DLL handle: 76FC0000 size: 498688 crc: 6DFDBB07 date: 2005-07-26 04:43:10
C:WINDOWSsystem32COMRes.dll handle: 77040000 size: 798208 crc: 32F92C44 date: 2004-08-04 12:00:00
C:WINDOWSsystem32dmime.dll handle: 60D90000 size: 181248 crc: AB73A81D date: 2004-08-04 12:00:00
C:WINDOWSsystem32DSOUND.dll handle: 73EE0000 size: 367616 crc: DBA2F3D7 date: 2004-08-04 12:00:00
C:WINDOWSsystem32dmusic.dll handle: 6CF20000 size: 104448 crc: E1760BED date: 2004-08-04 12:00:00
C:WINDOWSsystem32KsUser.dll handle: 73EB0000 size: 4096 crc: 354FE741 date: 2004-08-03 23:03:14
C:WINDOWSsystem32dmsynth.dll handle: 6CF40000 size: 103424 crc: F81FAB63 date: 2004-08-04 12:00:00
C:WINDOWSsystem32dmloader.dll handle: 6CFB0000 size: 35840 crc: 5B0F398E date: 2004-08-04 12:00:00
C:ProgramfilerwebHancerProgramswebhdll.dll handle: 10000000 size: 40960 crc: 4E4AFC61 date: 2005-10-26 09:04:26
C:WINDOWSsystem32mswsock.dll handle: 71A40000 size: 246784 crc: F1C0EDF0 date: 2004-08-04 12:00:00
C:WINDOWSsystem32hnetcfg.dll handle: 698D0000 size: 345088 crc: 7376FFC1 date: 2004-08-04 12:00:00
C:WINDOWSSystem32wshtcpip.dll handle: 71A80000 size: 19968 crc: F7B88996 date: 2004-08-04 12:00:00
C:WINDOWSsystem32Amhooker.dll handle: 01B10000 size: 36864 crc: 5D51C50C date: 2004-08-25 16:29:00
C:WINDOWSsystem32dmstyle.dll handle: 6CF60000 size: 105984 crc: 803104AB date: 2004-08-04 12:00:00
C:WINDOWSsystem32dmband.dll handle: 6D160000 size: 28672 crc: 038B742A date: 2004-08-04 12:00:00
C:WINDOWSsystem32psapi.dll handle: 76BE0000 size: 23040 crc: E7A6B8E7 date: 2004-08-04 12:00:00

System information:
Windows version 5.1 2600 Service Pack 2

I am using Windows Xp and the when i load the emergency save i plays for 2 seconds and then it chrashes. I have attached the last working savegame.
This task depends upon

Closed by  KUDr (KUDr)
Thursday, 11 May 2006, 23:10 GMT
Reason for closing:  Works for me
Comment by brygge_2 (brygge_2) - Thursday, 04 May 2006, 12:44 GMT
Here is the Latest Working Savegame
Comment by KUDr (KUDr) - Thursday, 04 May 2006, 19:10 GMT
Hmm, the savegame is huge (5.3 MB) and it is not accepted by flyspray..
Comment by KUDr (KUDr) - Thursday, 04 May 2006, 19:50 GMT
I am unable to reproduce it. Also I can't figure out where it crashed. So I can only wait for another (and hopefully better reproducible) case.
Comment by KUDr (KUDr) - Friday, 05 May 2006, 07:13 GMT
brygge_2: looks like it was not my build - can you please take last Zipped Windows Executable (4712) from forum http://www.tt-forums.net/viewtopic.php?t=24703 and try it again? This build is made by my compiler and i should be able to determine at least where it crashed. Thanks.
Comment by KUDr (KUDr) - Thursday, 11 May 2006, 19:24 GMT
no other crashes reported, closing...

Loading...