OpenTTD

Tasklist

FS#1487 - better highscore rules

Attached to Project: OpenTTD
Opened by Zdeněk Sojka (SmatZ) - Monday, 26 November 2007, 19:31 GMT
Last edited by andythenorth (andythenorth) - Tuesday, 15 August 2017, 18:44 GMT
Type Feature Request
Category Core
Status Closed
Assigned To andythenorth (andythenorth)
Operating System All
Severity Low
Priority Normal
Reported Version 0.6.0-beta1
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

ending_year is by default set to 2051, and can be changed only by console command 'patch ending_year xxx'

As far as I remember, ending_year should be set everytime new game is started to ending_year = starting_year + 100
Maybe there was some decision, so this is no longer valid
This task depends upon

Closed by  andythenorth (andythenorth)
Tuesday, 15 August 2017, 18:44 GMT
Reason for closing:  Won't implement
Additional comments about closing:  Flyspray clean up: more than 5 years old, and not obvious what should be done with this next, so closing. Game 'ends' in 2051, and changing it is not a current goal for OpenTTD. :) If this offends, discuss with andythenorth in irc. Thanks.
Comment by Benedikt Brüggemeier (skidd13) - Saturday, 01 December 2007, 18:47 GMT
Do you think of something like this?
Comment by Zdeněk Sojka (SmatZ) - Saturday, 01 December 2007, 20:11 GMT
As we had a talk at IRC-
it should be 101 years (1.1. 1950 - 31.12.2050)
and as this patch doesn't update starting year when starting from a scenario, it should be possible to set it in the scenario editor

(further changes, like setting the ending year in the Generator menu is possible - but not likely to come before 0.6)
Comment by Benedikt Brüggemeier (skidd13) - Sunday, 02 December 2007, 00:09 GMT
So here you are...
Comment by Benedikt Brüggemeier (skidd13) - Sunday, 02 December 2007, 00:30 GMT
Forget to add a line...
Comment by Benedikt Brüggemeier (skidd13) - Monday, 03 December 2007, 08:55 GMT
Added settings update for early games (pre revison 1496 AFAIS).
Comment by Benedikt Brüggemeier (skidd13) - Tuesday, 04 December 2007, 17:35 GMT
Added callbacks to protect against missusage of ending_year
Comment by Benedikt Brüggemeier (skidd13) - Monday, 04 February 2008, 10:59 GMT
Another attempt... (Concept)
This time I replaced ending_year with playtime. Hope the results will be nicer.
Ideas and comments would be nice.

Aside:
- A nice way of comparing the different playlengths in Singleplayer will be needed.
- There should be an option to lock the variable during game_mode.
Comment by Remko Bijker (Rubidium) - Sunday, 05 October 2008, 11:48 GMT
The graphics (newspaper) kinda requires that the highscore is shown in the end of 2050 (rather 1-1-2051). So technically the only place to use it is in network games and then you must reset it each and every time you start a new game.

So I'd vote for just removing it completely and "hardcode" 2051.
Comment by Benedikt Brüggemeier (skidd13) - Sunday, 05 October 2008, 12:36 GMT
Well graphics aren't problems for me ;)

Hardcoding is nice, but somehow it reduces the game a bit.

The highscore thing should be reworked, since its broken by design (no stable time dependance)...somehow.
Maybe the rework shall be included in the gamebalance rework.

Loading...