OpenTTD

Tasklist

FS#1482 - 65,528 Kirby Steam Tanks when i dont have 1 :S

Attached to Project: OpenTTD
Opened by eraser (eraser) - Sunday, 25 November 2007, 13:57 GMT
Last edited by Remko Bijker (Rubidium) - Tuesday, 04 December 2007, 20:34 GMT
Type Bug
Category Vehicles
Status Closed
Assigned To No-one
Operating System Windows
Severity Medium
Priority Normal
Reported Version 0.6.0-beta1
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Howdy All,
Just was playing on marteens server #1 and i went to replace some trains, and in the trains panel it states that i have 65.528 kirby steam tanks?? I dont have one. I have put a screenshot and a savegame. Im using 0.6.0B1, no grf's no mods. Not sure how or when this happened, so i havent tried replicating it.
Closed by  Remko Bijker (Rubidium)
Sunday, 09 December 2007, 15:18 GMT
Reason for closing:  Fixed
Additional comments about closing:  In r11605.
Comment by Jean-Francois Claeys (Belugas) - Sunday, 25 November 2007, 14:27 GMT
did that game come from a 0.5.3?
Or was it created by 0.6.0
Comment by eraser (eraser) - Sunday, 25 November 2007, 14:30 GMT
its from Marteens 0.6.0 server.
Comment by Remko Bijker (Rubidium) - Sunday, 25 November 2007, 14:34 GMT
As long as it isn't reproducible, it is not fixable as we do not have any idea when this occurs.
Comment by eraser (eraser) - Sunday, 25 November 2007, 14:38 GMT
I will keep a lookout for you.
Comment by Fragster (Fragster) - Wednesday, 28 November 2007, 08:52 GMT
sometimes i see it in r11527 or around it... but if I load saved game - I cant see this bug.
Comment by Remko Bijker (Rubidium) - Saturday, 01 December 2007, 09:43 GMT
That's because those numbers are recalculated at load. But even when they were not recalculated on load, we need to know where it starts going wrong not that is has been gone wrong a long time ago.
Comment by Zdeněk Sojka (SmatZ) - Tuesday, 04 December 2007, 19:52 GMT
Are there playing any AI players? ("AI in multiplayer" is on)
Comment by eraser (eraser) - Wednesday, 05 December 2007, 07:50 GMT
nope no playing AI player.

Loading...