OpenTTD

Tasklist

FS#1335 - I have a town with 5 billion people. It's 1920!??

Attached to Project: OpenTTD
Opened by paulicus25 (paulicus25) - Sunday, 14 October 2007, 14:06 GMT
Last edited by Remko Bijker (Rubidium) - Sunday, 06 January 2008, 23:38 GMT
Type Bug
Category Core
Status Closed
Assigned To No-one
Operating System All
Severity Low
Priority Normal
Reported Version trunk
Due in Version 0.6.0
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

I cama across a minor bug when playing a game on a recent ChrisIN version of OpenTTD. I have no idea what's caused this but it's defianately a bug either in the ChrisIN modificaion OR the actual OpenTTD Nighly.

Basically, after playing for about x months (i was playing on a day length x30 modifier) I noticed something odd when i used the town directory. 6 of the towns had should i say slightly "overcrowded populations. Somewhere in the region of just under 5 billion (american billion). This was clearly wrong as it was still 1920 and the town looked like it would be more like 1000 not 5 billion. I have attached a screenshot and a savegame.

The version that i used was ChrisIN r11204. I do not know whether you fix bugs in ChrisIN games, but i could find knowhere else to report this.

Thanks...
This task depends upon

Closed by  Loïc GUILLOUX (glx)
Tuesday, 15 January 2008, 00:08 GMT
Reason for closing:  Fixed
Additional comments about closing:  In r11855.
Comment by Benedikt Brüggemeier (skidd13) - Sunday, 14 October 2007, 14:11 GMT
ChrisIN is not supported by the OTTD devs. The best place to report the bug it to add a comment in the forum topic referring the ChrisIN.
Comment by Jonathan Coome (Maedhros) - Sunday, 14 October 2007, 14:12 GMT
I'm afraid we don't accept bugs for ChrisIN games, unless they can be reproduced in the nightlies. For what it's worth this looks like an underflow in the town population counter, but I've never seen or heard about it in the nightlies. Please post the bug in the ChrisIN thread on the forums, but feel free to reopen this bug if it's found to happen in trunk as well.
Comment by Phazorx (Phazorx) - Tuesday, 23 October 2007, 06:25 GMT
I'm affraid this issue is not relevant to ChrisIN since i encountered same problem while creating WWOTTDGD event map.
To best of my knowledge it is relevant to TTRS behavior around pre 1920 dates, even though I used TTRS 3.02a with params "0 5", after moving dates before 1920 and working in scenario editor with seeding industries. I ecountered some of original TTD buildings on the map, and in case if they are removed population takes a severe damn, much larger than original buildings have brought with them. Hence that results in population going down well bellow expected.

Unfortunately, due to massive amount of activity with that particular map, I can not at this time provide clear set of steps to reproduce this issue. However I'll try to get one as soon as I have time.

I find it unlikely that it is a player activity result since there was almost none of that in my case, and issue were not present in original map (CARST Europe) before I added TTRS grf (after demolishing everything on that map, towns were grown back from 0 via "expand" button). Looks very much like game engine/grf behavior around dates and different buildings types.
Comment by Remko Bijker (Rubidium) - Tuesday, 30 October 2007, 20:56 GMT
An actual savegame would be useful as I can't reproduce it.
Comment by paulicus25 (paulicus25) - Wednesday, 31 October 2007, 19:46 GMT
i have attached a savegame. if you look above, it will shhoe a .sav, and a screenshot to go with. Note it is a ChrisIN save.
Comment by Remko Bijker (Rubidium) - Wednesday, 31 October 2007, 22:21 GMT
Which means there still is no useable savegame that I can, or at least am willing to, debug.

I (/we as devs) do not have any knowledge of the things that happen in ChrisIN so it might very well be a ChrisIN issue that is happening in the ChrisIN save and something else that happens in 'vanilla' OTTD.
Comment by Remko Bijker (Rubidium) - Saturday, 10 November 2007, 23:13 GMT
Is there ANYONE who can make this reproduceable in OTTD trunk or the official nightlies (not ChrisIN or something like that)? Because if there is nobody who can, then it looks like someone's RAM messing things up.
Comment by arbitrary (arbitrary) - Saturday, 05 January 2008, 15:55 GMT
Can confirm on r11744 (using UKRS), steps to reproduce: blow up buildings (magic bulldozer) in Trestow, watch population wrap into negative.
(TTRS v3.02a, UKRS v3.03, UKRS Industries v2.01, UKRS Add-ons v3.03, New Stations v0.42.05.09.05, AA (av8)v1.331, GRVTS v1.0, New Water)
Comment by paulicus25 (paulicus25) - Friday, 11 January 2008, 17:16 GMT
Thanks. And that was pretty much the selection of graphics i was using. (But not grvtsv1.0, and had many other station graphics and unit sets to go with.) The thing was, i had towns with this insanely high population the moment i launched the game. I didnt need to destroy any of the town. It was 1921, with 1960's style buildings and before even unpausing the game it had got 4 billion people in. Very strange. Have not checked future games though...Should do really.
Comment by Loïc GUILLOUX (glx) - Friday, 11 January 2008, 18:42 GMT
@arbitrary: was it a new game or a scenario ?
Comment by arbitrary (arbitrary) - Friday, 11 January 2008, 21:56 GMT
It was a new game.

Loading...