OpenTTD

Tasklist

FS#1248 - r11118: wrong grouped trains counter

Attached to Project: OpenTTD
Opened by Doke (Doke) - Saturday, 22 September 2007, 09:16 GMT
Last edited by Remko Bijker (Rubidium) - Wednesday, 26 September 2007, 14:28 GMT
Type Bug
Category Vehicles
Status Closed
Assigned To No-one
Operating System All
Severity Low
Priority Normal
Reported Version trunk
Due in Version Undecided
Due Date 2007-09-22
Percent Complete 100%
Votes 0
Private No

Details

Revision: 11118

I created a new group, added one train and cloned this train several times in two different depots.
While the trains leaved the depots, i saw the counter in the group window showed "*group name* - 31 trains", although there were 42 trains showed in the list (trains nr. 596 to 637)
The counter behaves normal. When i added (or cloned) one train to the list it increases, else it decreases. I removed 32 trains from the list and the counter got from 0 to 65,535 trains (screenshot taken after i removed 5 more trains).

Maybe i renamed the station before cloning the trains in 2nd depot.

Savegame attached.
OS: Win XP

Just a small disfigurement. Happy debugging!
This task depends upon

Closed by  Remko Bijker (Rubidium)
Tuesday, 30 October 2007, 21:00 GMT
Reason for closing:  Unreproducible
Comment by Remko Bijker (Rubidium) - Saturday, 22 September 2007, 09:57 GMT
I'm unable to get this behaviour in a new game in the latest nightly/trunk.

Looking at the number of trains you're playing with you've been playing the game for quite some nightlies. As there have been a large range of these bugs in all kinds of corner cases it is most likely that your game is already messed up. The last of these cornercases should've been fixed in r11134, which is way after your savegame/you started the game.
Comment by Remko Bijker (Rubidium) - Wednesday, 26 September 2007, 14:27 GMT
Is this reproducable/recreatable in the latest nightly? If not then it's already fixed.

Loading...