OpenTTD

Tasklist

FS#120 - crashes in network game | pathfind.c assertion failed

Attached to Project: OpenTTD
Opened by maestro_alubia (maestro_alubia) - Friday, 14 April 2006, 20:33 GMT
Last edited by Darkvater (Darkvater) - Thursday, 27 April 2006, 08:28 GMT
Type Bug
Category Core
Status Closed
Assigned To richk67 (richk67)
Operating System Linux
Severity Low
Priority High
Reported Version 0.4.7
Due in Version 0.5.0
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Hi @all

My OpenTTD crashes every time I participate at this network game (see attachment). Until now I detected that this bug occurs in both, client and server mode and only with my linux-binary. the windows-version works fine and does not seem to be affected by this bug. removing the .openttd-folder in my home directory and starting in a fresh environment did not help. A few days ago, when we started this match, it did work fine and i have not changed anything relevant at my openttd-installation since that as far as I know.

so. the console shows only this output, when it has crashed:

pathfind.c:169: TPFMode2: Assertion `TileX(tile) != MapMaxX() && TileY(tile) != MapMaxY()' failed.

I had a look in this source-file but even though I can somehow understand the source code I do not have enough knowledge of it to find the cause of this bug.

so, any ideas or patches?

This task depends upon

Closed by  Darkvater (Darkvater)
Thursday, 27 April 2006, 08:29 GMT
Reason for closing:  Won't fix
Additional comments about closing:  New scenarios have been uploaded to SourceForge, please fetch those over at http://prdownloads.sourceforge.net/opent td/openttd-0.4.7-source-scenarios.zip?do wnload
Comment by Celestar (Celestar) - Saturday, 22 April 2006, 06:01 GMT
Ok there is something faulty with the map. It does not contain the mandatory shadow cells on the southern edges
Comment by Celestar (Celestar) - Saturday, 22 April 2006, 06:09 GMT
The scenario-of-question is wrong. Please refrain from using it until this has been fixed

Loading...