OpenTTD

Tasklist

FS#1094 - Foundations showing on 'build on slopes'

Attached to Project: OpenTTD
Opened by Ben Kings (Ben_K) - Monday, 30 July 2007, 09:22 GMT
Last edited by Jean-Francois Claeys (Belugas) - Sunday, 02 December 2007, 00:48 GMT
Type Feature Request
Category Core
Status Confirmed
Assigned To No-one
Operating System Windows
Severity Very Low
Priority Low
Reported Version trunk
Due in Version Undecided
Due Date Undecided
Percent Complete 0%
Votes 0
Private No

Details

Nightly version r10724 is my current version, however it has shown for a long while.

When build on slopes is used, the rear of the foundations sometimes shown. I think this is drawn into the sprites for the foundations, however, when I spoke to OzTransLtd he sent me a picture comparison with TTDPatch (See attached) where the problem doesnt occur.
This task depends upon

Comment by Remko Bijker (Rubidium) - Monday, 30 July 2007, 09:39 GMT
This is a tricky one:
1) we do not support building on tunnel entries, which is what these sprites are meant for.
2) in my opinion TTDP should show the foundation for the part that is not "covered" by the tunnel entry.
3) removing the foundation will cause another bugreport for not showing the foundation on the normal tunnel entry sprites.

So in my opinion both TTDP and OTTD are flawed in that image; it is just a little more visible that OTTD is flawed, but on the other hand we do not support building on tunnel entries which is the reason why the foundations are turned off in TTDP. I assume they are turned off for the normal tunnel entry sprites too, which I would classify as a bug.

Therefor I think there needs to be some method to turn those foundations partly off instead of totally removing them.
Comment by Ben Kings (Ben_K) - Monday, 30 July 2007, 09:50 GMT
That was kind of what I was thinking with it. If there is anything I can do to get more information, just let me know.

When I proposed it to OzTransLtd, I assumed TTDP was the same. Therefore, I suggested drawing new foundations that have grass one the back sections and he then sent that picture. Would new foundation graphics be a solution? Even if just a temporary one?
Comment by Peter Nelson (peter1138) - Monday, 30 July 2007, 09:52 GMT
New foundation graphics would have to be specific to the tunnel ends used. I vote for not-a-bug, as we don't allow building on tunnel heads.

If/When we do, it can be (probably) made to not draw that bit of foundation if there is track on the tunnel end.
Comment by Ben Kings (Ben_K) - Monday, 30 July 2007, 10:10 GMT
Well, Im an OTTD user, so I dont use that functionality (As its not there!) so I designed those tunnels to use with or without. This issue with the foundations just makes it look out of place. Its only aesthetic, so its your call I guess.

In the meantime, I guess I will have to get some new foundation sprites added to the GRF then.

Loading...