OpenTTD

Tasklist

FS#1062 - Crash when loading old savegame

Attached to Project: OpenTTD
Opened by Sven (Sven) - Saturday, 21 July 2007, 10:37 GMT
Last edited by Remko Bijker (Rubidium) - Monday, 30 July 2007, 08:23 GMT
Type Bug
Category Core
Status Closed
Assigned To No-one
Operating System Windows
Severity Critical
Priority Normal
Reported Version trunk
Due in Version 0.5.3
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Crashing on loading the attached savegame. I did not find a dmp file so I'm copying the information from the crash dialog:

*** OpenTTD Crash Report ***
Date: 2007-07-21 12:28:52
Build: 0.5.3-RC2 built on Jul 7 2007 22:29:43
Reason: !Disconnecting train
Exception C0000005 at 004222FA
Registers:
EAX: 0012F97C EBX: 00000001 ECX: 8DFB8D33 EDX: 002F016C
ESI: 00000200 EDI: 00037A51 EBP: 0012FB7C ESP: 0012F974
EIP: 004222FA EFLAGS: 00210246

Bytes at CS:EIP:
C6 05 00 00 00 00 00 A1 80 56 5C 00 85 C0 74 03 FF 50 04 53 E8 43 59 0A

Stack trace:
00000000 02E24010 73694421 6E6E6F63 69746365 7420676E 6E696172 00000000
00000500 000003CE CF010DAC 00000000 00000000 00000000 0012F9D4 75CA5AE9
75CA6A53 CF010DAC 75CA73D4 75CA5FC0 00000000 00000000 00000001 00000000
0012F9E4 75CA69B7 CF010DAC 75F9C18E 004388DA 000A04F8 0012FA20 0012FADC
0000000F 00000000 005BF6D0 000002D5 CF010DAC 31010EF2 0188000B 00000208
000002D5 00000000 0185000F 31010EF2 00000001 000002C4 00000206 000002ED
0000000F 00000000 0012FADC 880CB030 FF24AC20 81C76DBB FF24AC20 8F8DCF8F
000A04F8 0012F904 9CD099E8 0012FA8C 75FA1A10 000A04F8 0000000F 00000000
00000000 0000000F DCBAABCD 00000000 0012FADC 0000000F 0012FB04 0012FAB8
00000000 0012F9E0 0012FB04 75FA1B41 75FA1AFF 8DE97637 00000000 000A04F8
00ACAC20 00000024 00000001 00000000 00000000 00000070 FFFFFFFF FFFFFFFF
75FA1A91 75FA1B41 00000002 0012FB35 0012FB43 0012FAFC 0040B504 00000001
00000042 00000000 0012FB1C 0040BE44 FFFFEEAC 00000C38 00000003 02E66330
00000000 00000000 00003741 000001A0 00001D50 00000A3C 00000000 00001B9C
02E23F10 00037252 00000001 0012FB64 000020BC 00002CFA 02E23F10 000020A8
00000000 0012FBCC 00431A6C 00002CDF 000020A8 00002CFA 000020BC 00001B9C
02E23F30 0047082A 0012FBCC 0047103D 005390C4 00000001 02E6A850 02E6A850
0000001A 0000051F 00001BDF 00037C52 00037A51 02E6A850 00000010 00000000
00000000 00000000 00000000 02E23F30 00E6A850 00037052 0012FBE8 004715D4
00000001 02E6A850 02E6A850 00000000 005BF794 75F99FE9 00471635 00000001
005C443C 0042F417 00000000 00000000 0042317D 0039F363 00000000 0042345D
00000000 004392C6 005C27E4 005C45D8 0012FC7C 00000000 0039F381 00000000
00000000 000A04F8 0000000F 00000000 00000000 0039F363 000002D5 0000021C
00422B07 0012FD04 00000001 00000001 004D0800 00000000 0012FCA4 00001770

Module information:
C:Program FilesOpenTTDopenttd.exe handle: 00400000 size: 1355776 crc: EAD08299 date: 2007-07-07 20:30:48
C:Windowssystem32ntdll.dll handle: 773E0000 size: 1162656 crc: 9860BAFC date: 2006-11-02 09:47:26
C:Windowssystem32kernel32.dll handle: 77240000 size: 874496 crc: 17CD63D4 date: 2006-11-02 09:46:05
C:Windowssystem32WINMM.dll handle: 74120000 size: 193024 crc: 9854C61E date: 2006-11-02 09:46:14
C:Windowssystem32msvcrt.dll handle: 76110000 size: 681472 crc: 3E43316C date: 2006-11-02 09:46:10
C:Windowssystem32USER32.dll handle: 75F80000 size: 633856 crc: 43750877 date: 2007-06-29 23:15:43
C:Windowssystem32GDI32.dll handle: 75CA0000 size: 296448 crc: DEFE2EF3 date: 2006-11-02 09:46:05
C:Windowssystem32ADVAPI32.dll handle: 77320000 size: 770048 crc: 5657747A date: 2006-11-02 09:46:02
C:Windowssystem32RPCRT4.dll handle: 75E30000 size: 789504 crc: 341AB1A6 date: 2006-11-02 09:46:12
C:Windowssystem32ole32.dll handle: 770A0000 size: 1314816 crc: E94D6A09 date: 2006-11-02 09:46:12
C:Windowssystem32OLEAUT32.dll handle: 76350000 size: 558080 crc: 4240CB8B date: 2006-11-02 09:46:12
C:Windowssystem32OLEACC.dll handle: 740E0000 size: 214016 crc: 77FD0E8C date: 2006-11-02 09:46:12
C:Windowssystem32WS2_32.dll handle: 763E0000 size: 178688 crc: AAACD85A date: 2006-11-02 09:46:14
C:Windowssystem32NSI.dll handle: 77500000 size: 10240 crc: 7ABAD1AB date: 2006-11-02 09:46:12
C:Windowssystem32IMM32.DLL handle: 76020000 size: 115200 crc: 4E2420B1 date: 2006-11-02 09:46:05
C:Windowssystem32MSCTF.dll handle: 75D40000 size: 805888 crc: 15E5B0F8 date: 2006-11-02 09:46:06
C:Windowssystem32LPK.DLL handle: 75E20000 size: 24064 crc: F8DEC626 date: 2006-11-02 09:46:05
C:Windowssystem32USP10.dll handle: 77540000 size: 502784 crc: 92784FE4 date: 2006-11-02 09:46:13
C:Windowssystem32wdmaud.drv handle: 74030000 size: 168448 crc: 77A2240C date: 2006-11-02 09:44:42
C:Windowssystem32ksuser.dll handle: 740B0000 size: 4608 crc: 4C647881 date: 2006-11-02 09:46:05
C:Windowssystem32AVRT.dll handle: 75010000 size: 12800 crc: 55075A98 date: 2006-11-02 09:46:02
C:Windowssystem32MMDevAPI.DLL handle: 74D50000 size: 146944 crc: 8356CE09 date: 2006-11-02 09:46:05
C:Windowssystem32SHLWAPI.dll handle: 775C0000 size: 339968 crc: DD3E7F6D date: 2006-11-02 09:46:13
C:WindowsWinSxSx86_microsoft.windows.common-controls_6595b64144ccf1df_6.0.6000.16386_none_5d07289e07e1d100comctl32.dll handle: 74A40000 size: 1648128 crc: 3646BCFE date: 2006-11-02 09:38:57
C:Windowssystem32CLBCatQ.DLL handle: 76540000 size: 523776 crc: 80402F8D date: 2006-11-02 09:46:02
C:Windowssystem32SETUPAPI.dll handle: 761C0000 size: 1584128 crc: 0161B7EE date: 2006-11-02 09:46:13
C:Windowssystem32WINTRUST.dll handle: 74E40000 size: 171520 crc: CC0AAD60 date: 2006-11-02 09:46:14
C:Windowssystem32CRYPT32.dll handle: 75600000 size: 974336 crc: CE612123 date: 2007-06-29 23:15:58
C:Windowssystem32MSASN1.dll handle: 75750000 size: 59904 crc: 7A69072B date: 2006-11-02 09:46:06
C:Windowssystem32USERENV.dll handle: 75B50000 size: 107008 crc: 8A03C1B2 date: 2006-11-02 09:46:13
C:Windowssystem32Secur32.dll handle: 75B30000 size: 72704 crc: 8A267374 date: 2006-11-02 09:46:12
C:Windowssystem32imagehlp.dll handle: 77510000 size: 152576 crc: 04F330F8 date: 2007-07-03 18:24:27
C:WindowsSystem32audioses.dll handle: 73F60000 size: 115712 crc: EDAD9818 date: 2006-11-02 09:46:02
C:WindowsSystem32audioeng.dll handle: 73EF0000 size: 398848 crc: 6620F414 date: 2006-11-02 09:46:02
C:Windowssystem32PSAPI.DLL handle: 75C00000 size: 12288 crc: D7B812C5 date: 2006-11-02 09:46:12
C:Windowssystem32msacm32.drv handle: 73F90000 size: 21504 crc: BB7F5A40 date: 2006-11-02 09:44:42
C:Windowssystem32MSACM32.dll handle: 73970000 size: 73216 crc: D2218869 date: 2006-11-02 09:46:06
C:Windowssystem32midimap.dll handle: 73D90000 size: 17408 crc: 5B132C06 date: 2006-11-02 09:46:05
C:Windowssystem32uxtheme.dll handle: 74630000 size: 240640 crc: C7A510F1 date: 2006-11-02 09:46:13
C:Windowssystem32dmime.dll handle: 6D250000 size: 178688 crc: DAE0D69F date: 2006-11-02 12:34:33
C:Windowssystem32DSOUND.dll handle: 6F170000 size: 445440 crc: CDD4A072 date: 2006-11-02 09:46:04
C:Windowssystem32POWRPROF.dll handle: 75020000 size: 96768 crc: F38999AB date: 2006-11-02 09:46:12
C:Windowssystem32dmusic.dll handle: 6D070000 size: 101376 crc: 7F7DD187 date: 2006-11-02 12:34:33
C:Windowssystem32dmsynth.dll handle: 6D2F0000 size: 105472 crc: 098E46B7 date: 2006-11-02 12:34:33
C:Windowssystem32dmloader.dll handle: 72630000 size: 38400 crc: 9F2D389D date: 2006-11-02 12:34:33
C:Windowssystem32mswsock.dll handle: 75330000 size: 227328 crc: 292B63F9 date: 2006-11-02 09:46:10
C:WindowsSystem32wshtcpip.dll handle: 75000000 size: 11264 crc: 00CB0211 date: 2006-11-02 09:46:14
C:Windowssystem32dmstyle.dll handle: 6D050000 size: 105472 crc: 3B1A1D06 date: 2006-11-02 12:34:33
C:Windowssystem32dmband.dll handle: 6D420000 size: 30208 crc: 1AE3457D date: 2006-11-02 12:34:33
C:WindowsSystem32pmxscrll.dll handle: 10000000 size: 131072 crc: 8C186F05 date: 2007-03-28 10:12:32
C:WindowsSystem32PMXCOMM.dll handle: 00F00000 size: 49152 crc: 0A68D4F0 date: 2006-06-15 17:40:28
C:WindowsSystem32VERSION.dll handle: 753A0000 size: 20480 crc: 63E45BA2 date: 2006-11-02 09:46:13
C:Windowssystem32SHELL32.dll handle: 765D0000 size: 11314688 crc: 6DF63EAD date: 2006-11-02 09:46:13
C:WindowsSystem32PMXHOOKS.dll handle: 018B0000 size: 65536 crc: B7F8AD97 date: 2006-06-15 17:40:26

System information:
Windows version 6.0 6000
This task depends upon

Closed by  Remko Bijker (Rubidium)
Monday, 30 July 2007, 10:24 GMT
Reason for closing:  Fixed
Additional comments about closing:  In r10735.
Comment by Remko Bijker (Rubidium) - Sunday, 22 July 2007, 11:45 GMT
Have you saved that savegame with 0.5.3-RC1?
Comment by Patric Stout (TrueBrain) - Monday, 23 July 2007, 15:33 GMT
Loads fine under trunk. In 0.5.3-RC2 it crashes after a few seconds.
Comment by Sven (Sven) - Monday, 23 July 2007, 18:40 GMT
File was created with some older version of OTTD, not 0.5.3-RC1.

I can confirm that it loads successfully under r10663, so the issue seems fixed by changes made since releasing 0.5.3-RC2
Comment by Remko Bijker (Rubidium) - Monday, 23 July 2007, 21:40 GMT
Can you be more precise than "some older"?
Comment by Remko Bijker (Rubidium) - Monday, 23 July 2007, 22:11 GMT
And for completeness, the trunk change is not done after the release of 0.5.3-RC2. Trunk is totally independant from 0.5.whatever since 0.5.0-RC1.

The fact that it works in trunk is that there are major changes in the bridge handling code, but we cannot simply bring those changes to 0.5.X as that is way way too much work.
Comment by Sven (Sven) - Friday, 27 July 2007, 18:13 GMT
Unfortunately I can not be much more precise. The file dates back to 2006-03-04. I was using whatever beta or release candidate was up-to-date then. I did not mess with nighlies in those times :)

Loading...