OpenTTD

Tasklist

FS#1025 - Crash when loading newgrf with long description

Attached to Project: OpenTTD
Opened by Bilbo (bilbo) - Thursday, 12 July 2007, 00:09 GMT
Type Bug
Category Core
Status Closed
Assigned To No-one
Operating System All
Severity Low
Priority Normal
Reported Version trunk
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

In r10515:

When trying to add newGRF with longer description (like the one attached), the game crashes, saying "String too long for destination buffer". Ok, the description is quite long, but 540 characters is not so much and if there is some fixed size buffer, the description should be truncated at worst, not causing a crash.
This task depends upon

Closed by  Jean-Francois Claeys (Belugas)
Thursday, 12 July 2007, 01:34 GMT
Reason for closing:  Not a bug
Additional comments about closing:  PLease look at the comment I gave
Comment by Jean-Francois Claeys (Belugas) - Thursday, 12 July 2007, 01:33 GMT
May I point out that your grf is not very well received by TTDPatch itself? Look at the attached file...

From Action 08:
"Description
This is a longer description of the set. Typically it contains the name of the author and a copyright notice or other attribution. See GRFActionsDetailed for instructions to generate the necessary byte codes, and for restrictions on what characters you may use.

The description may be quite long, but should be short enough to fit in the description part of the GRF Status window, or a part of it may be cut off."

So please, do not ask us to fix what even TTDPatch does not tolerate...

Loading...