OpenTTD

Tasklist

FS#1020 - Ctrl+Q behaviour

Attached to Project: OpenTTD
Opened by Zdeněk Sojka (SmatZ) - Wednesday, 11 July 2007, 13:12 GMT
Type Bug
Category Core
Status Closed
Assigned To No-one
Operating System All
Severity Very Low
Priority Normal
Reported Version trunk
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

r10507
Hello, I encounter strange behaviour with Ctrl+Q keypress and exitting the game:

when I try to exit the game while the end-of-the-game screen is displayed, the game segfaults (Ctrl+Q + Enter) -> SIGSEGV

when autosave_on_exit = true and I try to exit the game (Ctrl+Q or from the menu), the *** SAVING *** text is not displayed and no confirmation dialog is shown (this may be intended behaviour)
This task depends upon

Closed by  Patric Stout (TrueBrain)
Friday, 13 July 2007, 15:02 GMT
Reason for closing:  Fixed
Additional comments about closing:  Fixed in r10548

Loading...