OpenTTD

Tasklist

FS#1015 - 'red box' message shown for non-dedicated servers

Attached to Project: OpenTTD
Opened by Zdeněk Sojka (SmatZ) - Tuesday, 10 July 2007, 11:28 GMT
Type Bug
Category Interface
Status Closed
Assigned To No-one
Operating System All
Severity Very Low
Priority Normal
Reported Version trunk
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

r10498

When a client sends an invalid request (eg. build road on water), the red box 'Cannot build road here' is shown for the game server, if it is not a dedicated server, and is controlling the same company. However, I was able to send invalid requests only with a modified client.

How to reproduce:
1) start a normal, unpatched, non-dedicated server
2) apply road.diff, copile and run a modified client
3) connect to the server to the same company as the server runs
4) try to build road on water
5) red box is shown for the server

(this could be changed not to cause desyncs, but would need more work)
This task depends upon

Closed by  Remko Bijker (Rubidium)
Tuesday, 10 July 2007, 20:59 GMT
Reason for closing:  Fixed
Additional comments about closing:  In r10501
Comment by Zdeněk Sojka (SmatZ) - Tuesday, 10 July 2007, 12:23 GMT
There may be some more problems -> in an openttdcoop game (r10438), I got messages like 'Cannot remove rail track from here' and 'You cannot purchase land' even when I was not doing anything... I didn't use any modified client.
Comment by Bilbo (bilbo) - Tuesday, 10 July 2007, 13:15 GMT
I think it sometimes happen when more people join same company, some error messages from one person's action like "You can't bulldoze that" or "you can't place road there" are shown for all people conected to that company. And since openttdcoop is many people in control of one company, these issues are more likely to happen there.

I saw the same issue in 0.5.2 some time ago when playing with another person in my company.

Loading...